Monitoring network connectivity
Incident Report for Captain Up
Resolved
This incident has been resolved.
Posted 5 months ago. Dec 27, 2017 - 13:46 IST
Monitoring
At this time network connectivity has been restored. We appreciate your patience as we worked through this and apologize for any issues this may have caused for you. If you continue to experience any issues, please contact us.
Posted 5 months ago. Dec 27, 2017 - 13:38 IST