We're currently having service errors
Incident Report for Captain Up
Resolved
The service is live. If you experience any issues, please contact us.
Posted over 1 year ago. Feb 16, 2016 - 16:08 IST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted over 1 year ago. Feb 16, 2016 - 15:58 IST
Investigating
We are on it, we will update again in 20 min or sooner if anything changes
Posted over 1 year ago. Feb 16, 2016 - 15:24 IST