Scheduled maintenance is currently in progress
Incident Report for Captain Up
Resolved
This incident has been resolved.
Posted about 2 years ago. Dec 07, 2015 - 18:59 IST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted about 2 years ago. Dec 07, 2015 - 15:29 IST