Scheduled maintenance is currently in progress.
Incident Report for Captain Up
Resolved
This incident has been resolved.
Posted about 2 years ago. May 09, 2015 - 16:30 IDT
Investigating
We are currently investigating this issue.
Posted about 2 years ago. May 09, 2015 - 15:25 IDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted about 2 years ago. May 09, 2015 - 12:19 IDT
Investigating
We will provide updates as necessary.
Posted about 2 years ago. May 09, 2015 - 07:55 IDT